[buddypress-trac] [BuddyPress Trac] #7226: Update BP_buttons class to accept new arg param for $element_type

buddypress-trac noreply at wordpress.org
Fri Aug 26 16:55:10 UTC 2016

#7226: Update BP_buttons class to accept new arg param for $element_type
 Reporter:  hnla         |       Owner:
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  2.7
Component:  Core         |     Version:
 Severity:  normal       |  Resolution:
 Keywords:  has-patch    |

Comment (by r-a-y):

 > We appear amongst other nomenclature changes to have changed element to

 I was thinking about this myself.  It's a trivial thing we could easily
 change.  Could go with `'element'` and `'attr'` if we wanted to.

 I thought since the parent element is namespaced with `parent`, we might
 want to namespace the actual button as well.  FWIW, the class is called
 `BP_Button`, the function names have the word `button` in them.

 I was also thinking about `wrapper` and whether we wanted to keep that as
 the `parent` namespace, since people might be accustomed to that name.

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/7226#comment:19>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list