[wp-trac] [WordPress Trac] #56130: Twenty Twenty-One: Load different CSS for different WP versions, to be compatible with blocks

WordPress Trac noreply at wordpress.org
Fri Jul 15 02:42:47 UTC 2022

#56130: Twenty Twenty-One: Load different CSS for different WP versions, to be
compatible with blocks
 Reporter:  poena          |       Owner:  (none)
     Type:  enhancement    |      Status:  new
 Priority:  normal         |   Milestone:  Awaiting Review
Component:  Bundled Theme  |     Version:
 Severity:  normal         |  Resolution:
 Keywords:                 |     Focuses:  css

Comment (by dd32):

 Replying to [comment:9 peterwilsoncc]:
 > Replying to [comment:7 poena]:
 > > Let's say I was using 6.0.1 and theme version 1.6.
 > > In 6.1 the new theme version is 1.7, but since I don't update core I
 can't activate 1.7.
 > >
 > > Would I get the security release if there was a version 1.6.1
 published to the theme directory?
 > Good question, I'll confirm with the meta folks.
 > Based on my reading of the code, it seems unlikely 1.6.1 would be
 offered but I am not an authority on how the WordPress update APIs work &
 how they choose what data to present.

 @peterwilsoncc is correct here, The WordPress.org Plugin & Theme
 directories only know about the latest release of a plugin/theme, in the
 event that a theme increases it's minimum WP or PHP requirements in a
 newer release, older sites would cease to receive update notifications -
 even to a newer (but older) version that does support their site.

 This is unfortunate, but is a technical simplification of the way the
 directories work. If in the future a Security release of a default theme
 was required, we could override this though (see below) and make it

 It should be noted, that Plugin Security releases which are done as
 "forced pushes" (ie. the WordPress.org Security team / Plugins team decide
 to enable automatic updates for the release) can override this, and in the
 past have statically defined the versions for a plugin - ie. 5.0 is the
 latest release, all 4.x-5.0 sites get autoupdated to 5.1 which requires WP
 >= 5.0, and all 2.0-3.9 sites get updated to 3.9.1 which supports WP < 5.0
 and is as secure as version 5.1.

Ticket URL: <https://core.trac.wordpress.org/ticket/56130#comment:11>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list