[wp-trac] [WordPress Trac] #10899: FTP password doesn't work if it contains an apostrophe

WordPress Trac wp-trac at lists.automattic.com
Sun Oct 4 11:54:15 UTC 2009

#10899: FTP password doesn't work if it contains an apostrophe
 Reporter:  ChadCloman    |       Owner:            
     Type:  defect (bug)  |      Status:  new       
 Priority:  normal        |   Milestone:  Unassigned
Component:  General       |     Version:  2.8.4     
 Severity:  normal        |    Keywords:            
 When automatically updating a plugin, I was asked for my FTP credentials.
 The FTP login always failed. I tried multiple times to get it to work, on
 multiple occasions.

 My password happened to include an apostrophe. I changed the password so
 that it no longer had the apostrophe. Then when I re-tried the FTP update,
 it worked.

 Note that it's not only the plugin update FTP that didn't work. There were
 other occasions where the WP admin pages asked for FTP credentials, and
 none of them worked with the apostrophe.

 I haven't looked through the code, but I'm assuming there's a generic
 input function that escapes special characters like apostrophes, and that
 this is why it didn't work.

 WordPress 2.8.4, Windows XP, Firefox 3.5.3

Ticket URL: <http://core.trac.wordpress.org/ticket/10899>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list