DD32 wordpress at dd32.id.au
Sun Mar 2 12:38:58 GMT 2008

On Sun, 02 Mar 2008 22:45:28 +1100, Jeremy Visser <jeremy.visser at gmail.com> wrote:

> I've put the following in wp-config.php to share my user tables among
> multiple WP installs:
>         define ('CUSTOM_USER_TABLE', 'wp_users');
>         define ('CUSTOM_USER_META_TABLE', 'wp_usermeta');
> However, I'm getting the infamous "You do not have sufficient
> permissions to access this page" error, and I'm not the first:
> <http://www.google.com/search?q=custom_user_table+"You+do+not+have+sufficient+permissions+to+access+this+page.">
> No solutions I've seen worked. My blog prefix is "wp_jv_", so I tried
> renaming the meta_keys "wp_capabilities" and "wp_user_level" in
> wp_usermeta to "wp_jv_capabilities" and "wp_jv_user_level", but no dice.
> Someone also suggested editing the following in
> wp-includes/capabilities.php:
>         $this->cap_key = $wpdb->prefix . 'capabilities';
> to this:
>         $this->cap_key = 'wp_capabilities';

That worked for me, Dont have any caches enabled?

However, Since WP has the Custom meta table define, Maybe it needs one so as to respect the meta table prefixes?

eg, In  your case, It attempts to load "wp_jv_capabilities" from the table "wp_usermeta", while "wp_usermeta" contains a "wp_capabilities" hey instead...

More information about the wp-hackers mailing list