Jeremy Visser jeremy.visser at gmail.com
Sun Mar 2 11:45:28 GMT 2008

I've put the following in wp-config.php to share my user tables among
multiple WP installs:

        define ('CUSTOM_USER_TABLE', 'wp_users');
        define ('CUSTOM_USER_META_TABLE', 'wp_usermeta');

However, I'm getting the infamous "You do not have sufficient
permissions to access this page" error, and I'm not the first:


No solutions I've seen worked. My blog prefix is "wp_jv_", so I tried
renaming the meta_keys "wp_capabilities" and "wp_user_level" in
wp_usermeta to "wp_jv_capabilities" and "wp_jv_user_level", but no dice.

Someone also suggested editing the following in

        $this->cap_key = $wpdb->prefix . 'capabilities';

to this:

        $this->cap_key = 'wp_capabilities';

No dice.

Obviously, something is broken. Can we try and track down what it is?
It's non-critical for me, but I'd still like to try and get to the
bottom of this.

Jeremy Visser                                 http://jeremy.visser.name/

()                           ascii ribbon campaign — against HTML e-mail
/\                                               http://asciiribbon.org/

More information about the wp-hackers mailing list