[wp-hackers] Plugin Management issue...

Alex nessence at gmail.com
Tue Jun 29 15:49:42 UTC 2004


You can also do crazy stuff like (what I probably shouldn't be doing):

# remove texturizer b/c preg doesn't like it
remove_filter('the_content', 'wptexturize');

# do our spell check - make sure it's last (eg, after acronyms if it's there)
# this way recognized acronyms don't end up as typos
add_filter('the_content', 'do_spell_check');

# put the texturizer back - after spell checker
add_filter('the_content', 'wptexturize');

texturize places things in the content dynamically. therefore, I
wanted my plugin executed beforehand because I just wanted the content
- not the content after being filtered. I also found the order of
executing these plugins was very difficult to manage. The best thing I
could think of might be a push_filter() or pop_filter()
function...that way you know your function is getting stuck at the
beginning or end - which is usually one of the places you want a
filter to be.



On Tue, 29 Jun 2004 08:13:51 -0700, Jason goldsmith <unteins at gmail.com> wrote:
> 
> Unfortunately the argument that the plugin load order is random is
> totally false.
> 
> The plugins currently have a very specific load order, they are loaded
> in the order they are activated, at least that's what David said.
> 
> Whether that was intentional or a happy accident isn't relevant
> anymore. There are developers who use the current order, so changing
> that behavior for 1 or 2 developers may hurt the 1 or 2 other guys who
> use it.
> 
> I totally agree that changing the plugin API willy nilly is not
> conducive to encouraging development. I think the better solution is
> to develop some way for plugins to specify that their loading should
> be delayed until some other plugin loads. It allows plugin authors who
> NEED this functionality to have it without the rest of the plugin
> developers having to rewrite their plugins.
> 
> As Kitty also pointed out, filename load order is going to lead to
> silly file names. WORSE it is going to lead to users saying, "I can
> never remember what 000000111111.php does, so I renamed it to
> SuperGroovy.php and now it broke."
> 
> 
> _______________________________________________
> hackers mailing list
> hackers at wordpress.org
> http://wordpress.org/mailman/listinfo/hackers_wordpress.org
>



More information about the hackers mailing list