[buddypress-trac] [BuddyPress Trac] #5914: Registration form: Proposed enhancements for touch devices

buddypress-trac noreply at wordpress.org
Fri Jan 2 11:24:37 UTC 2015

#5914: Registration form: Proposed enhancements for touch devices
 Reporter:  standardspace             |       Owner:
     Type:  enhancement               |      Status:  new
 Priority:  normal                    |   Milestone:  2.2
Component:  Theme / Template Parts    |     Version:
 Severity:  normal                    |  Resolution:
 Keywords:  good-first-bug has-patch  |

Comment (by hnla):

 @r-a-y Brilliant, nice patch. Think this approach justifies us adding
 these attributes then, accounting for mobile devices only, and filterable
 so we can modify if necessary.
 ''(taking things to the nth degree and only half suggesting this we could
 also test for webkit devices, there's quite a good open source class that
 tests for all manner of devices we could include, but it takes us into new
 realms that we probably don't want to head towards.)''

 Couple of points that spring to mind:

 1/ Should we not maybe rename the function from
 'bp_signup_field_attributes' to ? 'bp_touchdevice_input_attributes'
 suggesting this as we also need to take into account user settings
 password/email updating, and also as a helper function is it not more
 useful if the function is less specific to a screen or action/component
 than to the purpose the function returns, i.e we may have need of this
 function again perhaps in the future for form inputs yet to be written but
 also devs/plugin authors might then use the function for their custom form

 2/ Password fields: the default 'autocapitalize' value for general inputs
 is 'sentences' however for inputs of type="password" the default is
 'none', so in theory we need not specify the attribute on password fields
 technically, this is though for ios  >= 5

 3/ 'off' is deprecated in favour of 'none' again for ios => 5 so do we we
 run with deprecated values or take a decisions to support specific
 versions? It's another factor I'm uncomfortable with having BP now making
 decisions to support specific devices and needing to review that from time
 to time?

 4/ username fields: I think - but may have read things wrong - that we may
 actually need to describe 'autocapitalize' here as the default might take
 effect, we need this 'auto' behaviour disabled leaving the choice to
 capitalize in the users hands.

 Webkit/dveloper.apple reference:

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/5914#comment:11>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list