[wp-hackers] PHP 5.2 that WordPress 3.2 requires
wordpress at santosj.name
Sat Jul 24 22:12:25 UTC 2010
I agree with Nacin with this one. Just because the requirement is for
PHP 5.2.0, doesn't mean the server is required to use that version and
thankfully most should be at least PHP 5.2.2-6. It will be relatively
simple to test on latest for development and then switch to PHP5.2.0 for
regression testing and developing workarounds.
It is unlikely that WordPress will be using PDO and SPL at the WordPress
3.2.0 release. In fact, majority of SPL might as well be off limits
since the core developers with commit access has shown no interest in
updating the current paradigm to those newer (old) conventions .
While the requirement will be raised and possibility some backwards
compatibility with PHP4 will be removed, it seems unlikely that anything
really solidifying WordPress into PHP5.2 will happen in that version.
Of course, WordPress 3.2 is a year away, so much can and hopefully may
change during that time.
 The correct way of doing things be damned! :) Actually, I kid.
truthfully, the point Peter Westwood makes is that when you have to
rewrite large portions of existing and working code to match a
new-to-WordPress convention, then it requires a great deal of
contributor effort. Which means testing, fixes, more testing, more
fixes. Which increases the workload of what would seem to be a simple
fix. However, at some point the WTF?s that exist in WordPress will have
to be rewritten regardless, so either rewrite the code and ride the
defect train to slow improvement or include the new feature and slowly
move to the new code until it is tested and reasonably sure that no one
is using the old code.
On 7/24/2010 3:49 PM, Andrew Nacin wrote:
> On Sat, Jul 24, 2010 at 1:33 PM, Franklin Tse
> <peaceable_whale at hotmail.com>wrote:
>> I don't think it is good to stay in 5.2.0. One of the reasons to increase
>> the PHP version requirement, IMO, is to reduce the need of workarounds and
>> writing own implementation of PHP functions.
> And we are. For the following versions: 4.3.x, 4.4.x, 5.0.x, 5.1.x. Of all
> the problems we've had with PHP over the years, I'll gladly take PHP 5.2.0+
> as a minimum requirement and we can work around the bugs. That said:
> On Sat, Jul 24, 2010 at 12:53 PM, Stephen Rider<wp-hackers at striderweb.com>
>> If this is true, is there a *specific* reason we're choosing to go to only
>> 5.2.0 ? Aren't we just asking for headaches?
> We're asking for far less headaches than we currently have, that's for sure.
> Yes, the specific reason is we wanted to follow Joomla, Drupal, and the
> GoPHP5 initiative, and we believed that 5.2.0 would be adequate. The benefit
> of it being a major release helps a bit.
> Or do our usage statistics show a lot of people still using 5.2.0 ?
> I will check on this early next week -- I am curious as well.
>> Not arguing, just asking. Avoiding "critical" bugs seems like a good idea
>> to me....
> I agree! But we've been avoiding them for years under a wider number of
> versions. I like our chances against the critical bugs now.
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
More information about the wp-hackers