[wp-hackers] PHP 5.2 that WordPress 3.2 requires

Andrew Nacin wp at andrewnacin.com
Sat Jul 24 20:49:13 UTC 2010

On Sat, Jul 24, 2010 at 1:33 PM, Franklin Tse
<peaceable_whale at hotmail.com>wrote:

> I don't think it is good to stay in 5.2.0. One of the reasons to increase
> the PHP version requirement, IMO, is to reduce the need of workarounds and
> writing own implementation of PHP functions.

And we are. For the following versions: 4.3.x, 4.4.x, 5.0.x, 5.1.x. Of all
the problems we've had with PHP over the years, I'll gladly take PHP 5.2.0+
as a minimum requirement and we can work around the bugs. That said:

On Sat, Jul 24, 2010 at 12:53 PM, Stephen Rider <wp-hackers at striderweb.com>

> If this is true, is there a *specific* reason we're choosing to go to only
> 5.2.0 ?  Aren't we just asking for headaches?

We're asking for far less headaches than we currently have, that's for sure.
Yes, the specific reason is we wanted to follow Joomla, Drupal, and the
GoPHP5 initiative, and we believed that 5.2.0 would be adequate. The benefit
of it being a major release helps a bit.

Or do our usage statistics show a lot of people still using 5.2.0 ?

I will check on this early next week -- I am curious as well.

> Not arguing, just asking.  Avoiding "critical" bugs seems like a good idea
> to me....

I agree! But we've been avoiding them for years under a wider number of
versions. I like our chances against the critical bugs now.

More information about the wp-hackers mailing list