[wp-hackers] PHP 5.2 that WordPress 3.2 requires

Andrew Nacin wp at andrewnacin.com
Fri Jul 23 20:09:44 UTC 2010

On Fri, Jul 23, 2010 at 3:43 PM, Franklin Tse
<peaceable_whale at hotmail.com>wrote:

> I have noticed that the PHP 4 and MySQL 4 End of Life Announcement has been
> posted to the WordPress News blog. However, the announcement does not
> specify the PHP 5.2 version requirement exactly. For example, Joomla! 1.6
> requires PHP >=5.2.4 while Drupal 7 requires PHP >=5.2.0. Which PHP 5.2.x
> version do core developers want to support?
> If there are sufficient statistics, a higher subversion number is
> preferred. Earlier PHP 5.2.x has bugs that may be difficult to workaround,
> like http://forum.joomla.org/viewtopic.php?f=391&t=248927.


Like Drupal, the Joomla project is moving to 5.2.0. You may be confusing it
with their MySQL requirement for 1.6, which is MySQL 5.0.4.

(Drupal 7's MySQL requirement is 5.0.15, and we are matching that. 5.0.15 is
the first production version of the 5.0.x branch.)

More information about the wp-hackers mailing list