[wp-hackers] Plugin dependency checking

Stephen Rider wp-hackers at striderweb.com
Tue Jun 16 12:46:52 GMT 2009

On Jun 15, 2009, at 6:39 PM, Mike Schinkel wrote:

> As with discussion with Steven on the list, let me urge not to have  
> the child name its parent but instead have the child name the  
> "interface" that its parents can consume.  Steven called is "offers"  
> and "uses";

Just for the record, I wan't calling it anything, I was using the  
words as verbs.  ;-)  If we're going to find a terminology for it, I  
like the idea of an unambiguous metaphor for something that connects  
to something else:

Tab A/Slot B
toast/toaster  ;-)

I don't know what, exactly, but "interfaces" is too broad -- unless  
you know what it is, you don't know what it is.  If it's named  
properly authors can have an idea of how they work just from the name.


More information about the wp-hackers mailing list