[wp-trac] [WordPress Trac] #61565: Rename wp_maintenance to maybe_show_wp_maintenance

WordPress Trac noreply at wordpress.org
Wed Jul 3 18:45:17 UTC 2024


#61565: Rename wp_maintenance to maybe_show_wp_maintenance
--------------------------------------+------------------------------
 Reporter:  ramon fincken             |       Owner:  (none)
     Type:  enhancement               |      Status:  new
 Priority:  normal                    |   Milestone:  Awaiting Review
Component:  Bootstrap/Load            |     Version:  trunk
 Severity:  normal                    |  Resolution:
 Keywords:  has-unit-tests has-patch  |     Focuses:
--------------------------------------+------------------------------

Comment (by ramon fincken):

 The alternative would be:

 OPEN
 wp-settings.php

 FIND
 {{{#!php
 wp_maintenance();
 }}}

 REPLACE WITH
 {{{#!php
 if( wp_is_maintenance_mode() ) {
         do_wp_maintenance();
 }
 }}}

 OPEN
 wp-includes/load.php

 FIND
 {{{#!php
 function wp_maintenance() {
         // Return if maintenance mode is disabled.
         if ( ! wp_is_maintenance_mode() ) {
                 return;
         }
 }}}

 REPLACE WITH
 {{{#!php
 function do_wp_maintenance() {

 }}}

-- 
Ticket URL: <https://core.trac.wordpress.org/ticket/61565#comment:2>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform


More information about the wp-trac mailing list