[wp-trac] [WordPress Trac] #55597: WordPress 6.0-beta2-53224 not creating .htaccess

WordPress Trac noreply at wordpress.org
Fri Apr 22 10:22:03 UTC 2022

#55597: WordPress 6.0-beta2-53224 not creating .htaccess
 Reporter:  campation                            |       Owner:  (none)
     Type:  defect (bug)                         |      Status:  assigned
 Priority:  normal                               |   Milestone:  6.0
Component:  Permalinks                           |     Version:  trunk
 Severity:  critical                             |  Resolution:
 Keywords:  needs-testing needs-patch reporter-  |     Focuses:
  feedback                                       |

Comment (by campation):

 Hi @peterwilsoncc,

 I repeated everything this morning with a freshly downloaded WordPress
 6.0-beta2-53240 (ticket was opened for 52324):

 My environment
 - Linux Server Centos 7.9 with Plesk Onyx latest version (updated
 yesterday), 256GB RAM, 16 core etc, no web hosting
 - Nginx proxies requests to Apache
 - on this server some 30 productive WordPress websites (5.9.3) are
 running, I'm a plugin developer, too, so I know what I'm doing
 - subdomain https://beta.domain.com/ with SSL certificate
 - I tested WordPress 6.0 with PHP 7.4.29, 8.0.18 and 8.1.5
 - ***FPM by Nginx***

 Test procedure
 - create empty database
 - upload WP 5.9 by fpt
 - open frontend https://beta.domain.com/ and configuration and login as
 - .htaccess created as should be, everything working as usual

 then the same with WP 6.0 beta
 - delete all tables from database
 - delete www root on server
 - upload fresh unzipped WordPress 6.0-beta2-53240
 - open https://beta.domain.com/ and configuration and login as admin
 - no .htaccess created
 - this repeated with all 3 above mentioned versions of PHP - same result,
 the problem does not depend on PHP

 Strange to me after this test with WP 6.0:
 - .htaccess is missing
 - wp-config.php is left "writable by anybody" (rw-rw-rw 0666)
 - initial permalinks are set to
 "/index.php/%year%/%monthnum%/%day%/%postname%/" (/index.php is a fault)
 - setting other permalink structure is saved to db (without "/index.php")
 - still no .htaccess created
 - Apache error.log empty
 - calling hello-dolly -> 404

 I then tried the same with PHP 7.4.9 *** Nginx switched OFF ***
 - same result
 - no .htaccess
 - wp-config.php writable by everybody
 - permalink with "/index.php ...."

 So the problem does not seem to depend from PHP version nor Apache/Nginx

 Hope this helps!


Ticket URL: <https://core.trac.wordpress.org/ticket/55597#comment:3>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list