[wp-trac] [WordPress Trac] #51553: PHP 8.0: code improvements to allow for named parameters in function calls
WordPress Trac
noreply at wordpress.org
Thu Sep 9 15:17:35 UTC 2021
#51553: PHP 8.0: code improvements to allow for named parameters in function calls
-------------------------------------------------+-------------------------
Reporter: jrf | Owner:
| hellofromTonya
Type: task (blessed) | Status: reviewing
Priority: normal | Milestone: 5.9
Component: General | Version:
Severity: normal | Resolution:
Keywords: php8 has-patch needs-codex early | Focuses: coding-
needs-dev-note commit | standards
-------------------------------------------------+-------------------------
Comment (by hellofromTonya):
In [changeset:"51785" 51785]:
{{{
#!CommitTicketReference repository="" revision="51785"
Code Modernization: Fix parameter name mismatch with parent in
`WP_Customize_Custom_CSS_Setting::validate()`.
Renames the parameter to match the parent's method signature.
Why? PHP 8 introduces the ability to pass named arguments to
function/method calls. This means the child and parent method signatures
(i.e. parameter names) need to match.
Adds `@since` to clearly specify why the change happened.
Reassigns the generic parameter to the original parameter.
Why? Restoring the original name keeps the context intact within the
method and makes the code more readable. An inline comment explains why
this reassignment is made
Follow-up to [37476], [38829], [41376].
Props jrf, hellofromTonya, sergeybiryukov, azaozz, desrosj, johnbillion.
See #51553.
}}}
--
Ticket URL: <https://core.trac.wordpress.org/ticket/51553#comment:45>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform
More information about the wp-trac
mailing list