[wp-trac] [WordPress Trac] #51553: PHP 8.0: code improvements to allow for named parameters in function calls

WordPress Trac noreply at wordpress.org
Wed Sep 8 15:35:46 UTC 2021


#51553: PHP 8.0: code improvements to allow for named parameters in function calls
-------------------------------------------------+-------------------------
 Reporter:  jrf                                  |       Owner:
                                                 |  hellofromTonya
     Type:  task (blessed)                       |      Status:  reviewing
 Priority:  normal                               |   Milestone:  5.9
Component:  General                              |     Version:
 Severity:  normal                               |  Resolution:
 Keywords:  php8 has-patch needs-codex early     |     Focuses:  coding-
  needs-dev-note commit                          |  standards
-------------------------------------------------+-------------------------

Comment (by hellofromTonya):

 In [changeset:"51739" 51739]:
 {{{
 #!CommitTicketReference repository="" revision="51739"
 Code Modernization: Fix reserved keyword and parameter name mismatches for
 parent/child classes in `Walker::start_el()`.

 In the parent class, renames the parameter `$object` to `$data_object`.

 Why? `object` is a PHP reserved keyword.

 In each child class: renames the corresponding parameter to match the
 parent's method signature.

 Why?

 PHP 8 introduces the ability to pass named arguments to function/method
 calls. This means the child and parent method signatures (i.e. parameter
 names) need to match.

 Changes for readability:

 - `@since` clearly specifies the original parameter name and its new name
 as well as why the change happened.

 - in methods longer than a single line, the generic parameter is
 reassigned to the original parameter restoring it for context for use
 within the method. An inline comment is added to explain why this
 reassignment is made.

 - in cases where the original parameter name was too generic, renamed
 (when reassigning) to a more descriptive name for use within the method.

 Follow-up to [7737], [8900], [8970], [14248], [15077], [16100], [25642],
 [25644], [37051], [37054], [37056], [46271], [47189].

 Props jrf, hellofromTonya, sergeybiryukov, azaozz, desrosj, johnbillion.
 See #51553.
 }}}

-- 
Ticket URL: <https://core.trac.wordpress.org/ticket/51553#comment:37>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform


More information about the wp-trac mailing list