[wp-trac] [WordPress Trac] #36534: Media Upload Issue Since 4.5 Upgrade

WordPress Trac noreply at wordpress.org
Thu May 12 22:13:11 UTC 2016

#36534: Media Upload Issue Since 4.5 Upgrade
 Reporter:  unicornbacon             |       Owner:  joemcgill
     Type:  defect (bug)             |      Status:  reopened
 Priority:  normal                   |   Milestone:  4.5.3
Component:  Media                    |     Version:  4.5
 Severity:  major                    |  Resolution:
 Keywords:  has-patch needs-testing  |     Focuses:

Comment (by mouriana):

 Replying to [comment:47 swissspidy]:
 > I'm a bit worried about seeing so many reports of breakage.
 > @ all: If you're affected by this bug, it would be great if you could
 test [attachment:36534.diff] by applying those changes to `wp-includes
 /class-wp-image-editor-imagick.php` and write here if it works.
 > @joemcgill How confident would you be with shipping
 [attachment:36534.diff] in 4.5.3 and improve things in 4.6 as you
 previously suggested?

 OK, so I'm pretty new to the whole WordPress thing (or any web coding at
 all for that matter, though I have a few years of DB and IT experience
 under my belt), so forgive me if I'm crazy stupid.  I am using WP 4.5.2 on
 PHP 5.6.
 Have been working on 3 separate sites (with 3 separate templates) and
 getting this error for a little over 24 hours now, though it is happening
 most consistently on the site that is using the Nisarg template.  I have
 tried shrinking image sizes, using the browser uploader, making the media
 size huge under tools, editing the themes function file, adding the line
 to the .htaccess file, and applying the aforementioned 36534.diff patch.
 Nothing works.  If I am trying to add to a page, I get the HTTP error.  If
 I am simply trying to add to my library, it just stops (with MOST images,
 not all, but my largest image is 4.87 MB), gives me no error, but if I go
 to the library, the image is listed with no thumbnail.  If I click 'view,'
 the image comes up but I get the following errors:

 Warning: Illegal String Offset 'Width' In /src/Wp-
 Content/Themes/Nisarg/Image.Php On Line 31

 Warning: Illegal String Offset 'Height' In /src/Wp-
 Content/Themes/Nisarg/Image.Php On Line 32

 The image is likewise unusable, though I can see it.
 Now, if I turn off all my plugins (I only have Jetpack, Event Calendar WD,
 and Akismet running) AND shrink one of these images by 50% (75% doesn't do
 it) and try to upload it, it actually crunches it (it doesn't normally do
 this), and works.  However, if I do all those steps except only shrink it
 to 75%, it TRIES to crunch it, and I get this error:
 Fatal error: Out of memory (allocated 39845888) (tried to allocate 450
 bytes) in /src/wp-includes/media.php on line 2751

 I am using 1and1 for my host and as far as I can tell the size is set
 correctly on the host end (plus this is behaving erratically from site to
 site, all of which are hosted on the same package).  I can call them, but
 by now I am tired. :P

 Hope that wasn't too much information; I'm new enough to this that I'm
 trying to be thorough.

Ticket URL: <https://core.trac.wordpress.org/ticket/36534#comment:48>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list