[wp-trac] [WordPress Trac] #32553: Corrupted embeds

WordPress Trac noreply at wordpress.org
Tue May 10 16:30:56 UTC 2016

#32553: Corrupted embeds
 Reporter:  pavelevap          |       Owner:
     Type:  defect (bug)       |      Status:  reopened
 Priority:  normal             |   Milestone:
Component:  Embeds             |     Version:  4.1.5
 Severity:  normal             |  Resolution:
 Keywords:  reporter-feedback  |     Focuses:
Changes (by kranzoky):

 * status:  closed => reopened
 * resolution:  invalid =>


 I am experiencing the same issue as OP.

 When inserting in Tweet URLs into a post, all the URLs will work initially
 and be automatically converted to the Embed.

 However, after the post is edited and saved a few times, I notice that
 some of the URLs in the post just stay URLs and don't get converted.

 I did notice that when I click on the URLs that don't end up working in
 the editor that they are wrapped in paragraph tags.

 I also noticed that when I even try to grab those URLs that don't work and
 insert the Tweet using the "Insert from URL" in the insert media dialogue
 box that even that method does not work. I will paste in the Tweet URL and
 nothing happens. It doesn't get converted to an embed.

 I was able to get the embeds working by using a plugin called "Oembed
 Cache". Using that plugin, I deleted the Oembed Cache for the post and
 then tried embedding the tweets again and it worked. Why would some
 oEmbeds in my post be getting corrupted?

Ticket URL: <https://core.trac.wordpress.org/ticket/32553#comment:5>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list