[wp-trac] [WordPress Trac] #38681: Rename WP_User::for_blog() to WP_User::for_site()

WordPress Trac noreply at wordpress.org
Wed Dec 7 16:13:08 UTC 2016

#38681: Rename WP_User::for_blog() to WP_User::for_site()
 Reporter:  flixos90                  |       Owner:
     Type:  enhancement               |      Status:  closed
 Priority:  normal                    |   Milestone:
Component:  Users                     |     Version:
 Severity:  normal                    |  Resolution:  maybelater
 Keywords:  has-patch has-unit-tests  |     Focuses:  multisite
Changes (by flixos90):

 * status:  new => closed
 * resolution:   => maybelater
 * milestone:  4.8 =>


 Per discussion at WCUS Contributor Day, we won't rename the method.
 Instead we will use `for_blog()` as name for the new method introduced in
 #38645 to have parity. A rename process can happen once we start
 implementing more network-related features (`switch_to_network()` for
 example) as many of these functions will also be changed internally a bit.

Ticket URL: <https://core.trac.wordpress.org/ticket/38681#comment:5>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list