[wp-trac] [WordPress Trac] #32438: Drag & Drop media uploader breaks in FireFox Developer Edition 40.0a2 (2015-05-18)

WordPress Trac noreply at wordpress.org
Tue May 19 10:30:48 UTC 2015

#32438: Drag & Drop media uploader breaks in FireFox Developer Edition 40.0a2
 Reporter:  Jacotheron    |      Owner:
     Type:  defect (bug)  |     Status:  new
 Priority:  normal        |  Milestone:  Awaiting Review
Component:  Upload        |    Version:  4.2.2
 Severity:  normal        |   Keywords:
  Focuses:                |
 When dragging the image into the drop area, the file is added to the list
 to upload, but the upload never happens - Immediate "HTTP error"

 '''What have I tried:'''
 I debugged the WordPress install using the recommended methods (disabled
 plugin, modifying chmod, added .htaccess rules, increased memory,
 increased upload & post sizes, tested on different servers including
 production, staging, and local vagrant installs). Nothing works, although
 it previously worked.

 I continued the debugging, and found that:
 1. Browser Uploader works
 2. Clicking inside the Drag & Drop area and select image(s) works
 3. Dragging any file into the Drop area resulted in an immeditate "HTTP

 I continued to compare the requests (using FireBug) - they are identical
 (only difference was the boundry value). Their Post data length was the
 same (although I was not able to see and compare the data itself).

 In the Dragged File's request, there was no response (request is sent, but
 no reply, not even response headers). I even modified the receiving php
 file to quit immediately with a message (message did not come through).
 Making a manual request to the receiving file resulted in a WordPress
 branded error (which is expected).

 I continued and tested it in my other browsers, all other browsers worked
 as expected.

 It affects only FireFox Developer Edition (after it updated to version

 '''Possible Cause:'''
 It could be a change in how Firefox handles files being dropped onto a

 '''Additional Info:'''
 This issue also affects other websites (like Shopify specifically),
 however Google have already solved it on Google+ (which is why I believe
 it is just a minor change in Firefox's API; if it is an API change, it
 would be nice to have it work when Firefox Stable updates in about 5-6

 I am using a Windows computer for Firefox, WordPress 4.2.2 (running on
 Linux installs, either via VVV, or Remotely), PHP versions 5.5 and 5.6,
 Apache and Nginx servers.

 I tried multiple different files, file types and file sizes, works only
 when selecting through the file selection interface.

Ticket URL: <https://core.trac.wordpress.org/ticket/32438>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list