[wp-trac] [WordPress Trac] #31378: Updating from 4.1 to 4.1.1 fails after submitting FTP credentials - returns blank page

WordPress Trac noreply at wordpress.org
Sat Feb 21 21:35:14 UTC 2015

#31378: Updating from 4.1 to 4.1.1 fails after submitting FTP credentials - returns
blank page
 Reporter:  remi123          |       Owner:
     Type:  defect (bug)     |      Status:  reopened
 Priority:  normal           |   Milestone:  4.1.2
Component:  Upgrade/Install  |     Version:  4.1
 Severity:  major            |  Resolution:
 Keywords:                   |     Focuses:

Comment (by andrebron):

 Side note, perhaps not related to this bug, but very interesting...
 Seemed to be a server side issue for me with php5-fpm on Debian 7.
 Probably after a php-fpm update...

 Reloading php-fpm daemon resulted in the Core 4.1.1 update being applied
 and the following error showing up on the updates screen below Admin
 dashboard top menus bar:

 Warning: mysql_connect(): Headers and client library minor version
 mismatch. Headers:xxxxx Library:xxxxx in /var/www/spectrohost/web/wp-
 includes/wp-db.php on line 1416

 This warning can be resolved by installing and using php5-mysqlnd:

 apt-get install php5-mysqlnd

 Replying to [comment:9 andrebron]:
 > Interesting situation for me...  Dev site updated fine, but production
 site does not.  They are on 2 different servers running same OS,
 permissions and such.  Disabled firewalls...
 > Tried adding/removing  (FS_METHOD).  No go for me.
 > Manually updating WordPress Core files does not work either.  Very
 > After manually updating all core files (except wp-content), Admin
 Dashboard still not updating.  Some db update issue perhaps?
 > Updating to Core 4.1.1 tries the update, then no errors are shown, then
 refreshes back to the updates screen without having completed the update
 to Core 4.1.1.
 > @dd32 What Core file has `$_POST['version']` set to pass to the FTP
 credentials screen?
 > Replying to [comment:5 dd32]:
 > > A bug is present in 4.1 which has resulted in `$_POST['version']` not
 being passed through the FTP credentials screen, and as a result, it fails
 to find a update package to use, and returns early with a blank screen..
 > >
 > > I've just deployed a change to api.wordpress.org which should work
 around this, with the downside that the Update screen will display a
 duplicate update offering on the update screen.
 > >
 > > If you're still running 4.1, and affected by this, please try updating
 again from '''Dashboard -> Updates'''?

Ticket URL: <https://core.trac.wordpress.org/ticket/31378#comment:10>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list