[wp-trac] [WordPress Trac] #30787: Shrinkwrap NPM dependencies

WordPress Trac noreply at wordpress.org
Tue Dec 15 09:33:35 UTC 2015

#30787: Shrinkwrap NPM dependencies
 Reporter:  jorbin            |       Owner:
     Type:  enhancement       |      Status:  new
 Priority:  normal            |   Milestone:  4.4.1
Component:  Build/Test Tools  |     Version:
 Severity:  normal            |  Resolution:
 Keywords:  2nd-opinion       |     Focuses:

Comment (by netweb):

 @nacin Backporting r35859 via #35003 to the 4.4 build branch _should_ fix
 up those errors:

 Also we should be using at least NodeJS v0.12.x as PostCSS requires this
 v0.12.x or greater, and WordPress includes two node modules that use
 PostCSS, Autoprefixer and RTLCSS.

 I'd be tempted to actually recommend that we bump up our minimum supported
 NodeJS version to v4.x LTS per the
 [https://nodejs.org/en/blog/community/node-v5/ LTS announcment], this
 brings back compatibility of IO.JS and NodeJS branches and gives us a
 somewhat more dependable NodeJS base that module owners are aware of for
 maintaining backcompat for this NodeJS version.

Ticket URL: <https://core.trac.wordpress.org/ticket/30787#comment:9>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list