[wp-trac] [WordPress Trac] #23880: Minimum PHP version in Plugins

WordPress Trac noreply at wordpress.org
Thu Aug 13 16:31:22 UTC 2015

#23880: Minimum PHP version in Plugins
 Reporter:  TJNowell         |       Owner:
     Type:  feature request  |      Status:  closed
 Priority:  normal           |   Milestone:
Component:  Plugins          |     Version:
 Severity:  normal           |  Resolution:  wontfix
 Keywords:                   |     Focuses:

Comment (by jb510):

 Replying to [comment:48 alexander.rohmann]:
 > Would not bumping the minimum version for core be the more
 straightforward way to address this? Personally, I don't care for an
 official way in core to provide a minimum version. In a way that promotes
 fracturing the plugin ecosystem. It's just dipping your toe in the water.
 It would seem developers are already solving this in the plugin code
 itself. My point is that for development to evolve, WordPress itself needs
 to natively support modern PHP.

 I don't think so.  There are other tickets about bumping core's PHP
 version and while that will eventually happen that doesn't address the
 specifics of this ticket.

 Bumping core today would solve the immediate problem but it doesn't
 address that has been and continues to be an on-going problem where core
 allows users to blindly activate a plugin that might not be compatible
 with their current hosting environment.

 Don't think about PHP 5.4, think about 7.0.  What happens when plugins
 start requiring PHP 7.0?  WordPress is going to run fine on 7.0 (it
 already does actually) long before core _requires_ 7.0.

 You're right, some developers are solving this by checking the PHP version
 in their plugin before running, but some of us think that's redundant and
 this would be better handled by core.   There ought to be a standard way
 to handle it across all plugins.  Where core reads the comment block and
 says "hey, sorry I can't activate plugin X because it says it requires PHP
 7.0 and this server is running PHP 5.6".

 In fact the recent PHP constructor change bring up that there should
 probably also be a maximum version specified in some cases.

Ticket URL: <https://core.trac.wordpress.org/ticket/23880#comment:49>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list