[wp-trac] [WordPress Trac] #25393: Hook Docs: wp-login.php
WordPress Trac
noreply at wordpress.org
Tue Sep 24 02:53:58 UTC 2013
#25393: Hook Docs: wp-login.php
-------------------------+------------------------------
Reporter: ShinichiN | Owner: kpdesign
Type: enhancement | Status: reviewing
Priority: normal | Milestone: Awaiting Review
Component: Inline Docs | Version:
Severity: normal | Resolution:
Keywords: needs-patch |
-------------------------+------------------------------
Changes (by DrewAPicture):
* keywords: has-patch => needs-patch
Comment:
[attachment:wp-login-3.diff] is getting there. Unfortunately, there's
still some work to do yet. Here are my notes:
* "password retrieving process." should be "password retrieval process."
* In my opinion, `// Misspelled and deprecated ` should be in a doc block
even if the action is deprecated.
* `allow_password_reset` filter: "Filter password reset restriction
boolean." is pretty vague. Can you better clarify what is filterable here?
Also, "True as default." should be a short description of what the
parameter is. It's fine to append the default to the end, but we should
know what it signifies
* "Fires before inserting the new md5 key into database." should be
clearer. What md5 key are we talking about? The activation key?
* `login_init`: what does "the main action of wp-login.php" refer to
exactly?
* `lostpassword_redirect`: I suggest splitting the follow out to a
variable first, then using the variable in the filter and documenting it,
respectively: `!empty( $_REQUEST['redirect_to'] ) ?
$_REQUEST['redirect_to'] : ''`. Perhaps `$lostpassword_redirect` or
something
* `lostpassword_form`: The short description, "Fires in the lostpassword
form to add extra hidden input.", makes an assumption about what specific
type of action will happen here. Maybe something like this instead? "Fires
in the lostpassword form before the hidden fields."
* `register`: I suggest splitting the following out to a variable above
the filter: `printf( '<a href="%s">%s</a>', esc_url( wp_registration_url()
), __( 'Register' ) )`
* `register_form`: "form to add extra input." should be plural: "form to
add extra inputs."
* `login_redirect`: Split the following out to a variable above the
filter, same as `lostpassword_redirect`: `isset( $_REQUEST['redirect_to']
) ? $_REQUEST['redirect_to'] : ''`.
If you have questions about any of the suggestions I listed or need help,
let me know. Happy to help :)
--
Ticket URL: <http://core.trac.wordpress.org/ticket/25393#comment:5>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software
More information about the wp-trac
mailing list