[wp-trac] [WordPress Trac] #16490: Rename is_x_admin() functions to in_x_admin()

WordPress Trac wp-trac at lists.automattic.com
Tue Feb 8 18:32:46 UTC 2011

#16490: Rename is_x_admin() functions to in_x_admin()
 Reporter:  apeatling            |       Owner:
     Type:  enhancement          |      Status:  new
 Priority:  normal               |   Milestone:  Future Release
Component:  Administration       |     Version:  3.1
 Severity:  normal               |  Resolution:
 Keywords:  has-patch 3.2-early  |

Comment (by westi):

 -100 for {{{in_admin( $where )}}}.

  1. We don't envisage adding any more $wheres in the near term
  2. It makes the code harder to read, scan for relevant checks etc.
  3. It doesn't really make things less confusing than {{{in_admin()}}} /
 {{{in_user_admin()}}} / {{{in_network_admin()}}}

Ticket URL: <http://core.trac.wordpress.org/ticket/16490#comment:16>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list