[wp-trac] [WordPress Trac] #13782: query_posts and strict boolean
WordPress Trac
wp-trac at lists.automattic.com
Tue Jun 8 20:04:21 UTC 2010
#13782: query_posts and strict boolean
-----------------------------+----------------------------------------------
Reporter: arena | Owner: ryan
Type: feature request | Status: new
Priority: normal | Milestone: Future Release
Component: Query | Version:
Severity: normal | Keywords:
-----------------------------+----------------------------------------------
Comment(by filosofo):
Replying to [comment:3 arena]:
> @filosofo,
>
> i attached a sample patch
What I was trying to get at is that we shouldn't call it "strict" unless
it's actually strict in a general, meaningful sense. If you just want an
ad hoc solution to the particular problem, better to call it something
more specific. Let's reserve "strict" for when we can actually make it
strict.
So a more specific ad hoc solution would be, for example, to create a new
query var called something like `mandatory_cat` which if called the given
singular post must have.
{{{
query_posts(
array(
'p' => 123,
'mandatory_cat' => 456,
)
);
}}}
--
Ticket URL: <http://core.trac.wordpress.org/ticket/13782#comment:4>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software
More information about the wp-trac
mailing list