[wp-trac] Re: [WordPress Trac] #10079: Codepress not loaded when using administration over SSL

WordPress Trac wp-trac at lists.automattic.com
Wed Jun 10 08:18:17 GMT 2009

#10079: Codepress not loaded when using administration over SSL
 Reporter:  riivolepp       |       Owner:                   
     Type:  defect (bug)    |      Status:  new              
 Priority:  normal          |   Milestone:  2.8              
Component:  Administration  |     Version:  2.8              
 Severity:  normal          |    Keywords:  reporter-feedback

Comment(by riivolepp):

 It's set as following:
 var codepress_path = 'https://sitename/wp-includes/js/codepress/';

 Also tried to manually change it to http://.. but it will give exactly the
 same error.
 I searched from code that this variable only used by codepress.js #43.

 When access file https://sitename/wp-includes/js/codepress/codepress.html
 directly from browser it will redirected correctly to http://sitename/wp-

 I think the problem is that browser security doesn't run http: scripts
 when main page comes from https:

 As a workaround I copied codepress catalog to /wp-admin/js and changed
 codepress_path to that.

Ticket URL: <http://core.trac.wordpress.org/ticket/10079#comment:2>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list