[wp-meta] [Making WordPress.org] #4341: Import translations doesn't work with JSON format

Making WordPress.org noreply at wordpress.org
Thu Mar 28 00:28:55 UTC 2019

#4341: Import translations doesn't work with JSON format
 Reporter:  Amieiro                  |      Owner:  (none)
     Type:  defect                   |     Status:  new
 Priority:  normal                   |  Milestone:
Component:  Translate Site &         |   Keywords:  has-screenshots needs-
  Plugins                            |  patch
 I am translating the "WordPress Importer" plugin to Galician language

 My workflow is:

 1. I export a JSON file with the strings to be translated (only one string
 in my example). See screenshot-01.png. The output file is wp-plugins-
 2. I add the translation to the file (one string). I have tried 3 options.
    a. UTF-8 LF (Unix end of line type) with accent mark in Unicode, as I
 have seen in other translations. The result file is wp-plugins-wordpress-
    a. UTF-8 LF (Unix end of line type) with accent mark without Unicode.
 The result file is wp-plugins-wordpress-importer-dev-gl-03.json.
    a. UTF-8 LF (Unix end of line type) without accent mark, only with
 english characters. The result file is wp-plugins-wordpress-importer-dev-
 3. I tried to upload each of this files (see screenshot-02.png) but I
 don't get any translations added (see screenshot-03.png).
 4. To check that the string exists and it is not translated, I copy the
 original string from the JSON file (english string), paste it in the
 search box (see screenshot-04.png) and I find the string untranslated (see

 I think the importer with JSON files is not working correctly.

Ticket URL: <https://meta.trac.wordpress.org/ticket/4341>
Making WordPress.org <https://meta.trac.wordpress.org/>
Making WordPress.org

More information about the wp-meta mailing list