[wp-meta] [Making WordPress.org] #3551: Plugin Directory: Requires PHP: Standardise on values

Making WordPress.org noreply at wordpress.org
Thu Apr 5 06:41:41 UTC 2018

#3551: Plugin Directory: Requires PHP: Standardise on values
 Reporter:  Dion Hulse        |      Owner:  (none)
     Type:  defect            |     Status:  new
 Priority:  normal            |  Milestone:
Component:  Plugin Directory  |   Keywords:  needs-patch
 Following on from #2952 a lot of plugins have started implementing the
 `Requires PHP` header.

 Unfortunately, a lot of them are not following any form of computer-
 readable standard.

 For example, a quick selection:
 PHP 4
 4.6 or greater
 5.6 or later
 4 & 5
 5.6 or 7.0
 5.6 or higher
 >= 5.4
 5.4 and higher
 (PHP 5.6 + libsodium extension) or (PHP 7.2 or above)
 (Yes, some plugins have specified they're PHP 4 compatible, I doubt they

 A quick look suggests that 2,715 plugins have specified a sane identifier
 (x.y, or x.y.z) with a further 156 plugins specifying it in ways such as
 the above list which make it harder to pragmatically use.

 I'd recommend that we validate the number in some form in the readme
 parser to make the data more useful long term.
 I'd suggest
  - Require the version number be specified as `x.y` or `x.y.z`
  - If Other data is in there, pull out the first version-like string, ie.
 `5.3` from `5.3+`, `5.3 or greater`, or `5.3-7.1`. Based on existing data,
 it looks like that should be fine.
  - Add a warning to the readme validator when unexpected values are
 encountered and note if it's truncated/sanitised to something reasonable.

Ticket URL: <https://meta.trac.wordpress.org/ticket/3551>
Making WordPress.org <https://meta.trac.wordpress.org/>
Making WordPress.org

More information about the wp-meta mailing list