[theme-reviewers] Bundling libraries and prefixing
grapplerulrich at gmail.com
Thu Feb 27 15:02:46 UTC 2014
I would say no because if you have a plugin that uses novo slider also then
you will load the script twice which can cause issues and is stupid to load
the script twice.
There should be a standard naming convention. So if the script is dependent
on Jquery it should be jquery-nivo-slider.
On 27 Feb 2014 15:35, "Rohit Tripathi" <rohitink at live.com> wrote:
> It should be
> wp enqueue_script( 'themename-nivo-slider', ... );
> As the rule states, all theme defined hooks/functions should be properly
> > Date: Thu, 27 Feb 2014 08:32:38 -0600
> > From: kovshenin at gmail.com
> > To: theme-reviewers at lists.wordpress.org
> > Subject: [theme-reviewers] Bundling libraries and prefixing
> > Quick question.
> > If a theme bundled the Twitter Bootstrap library, or Nivo Slider, or
> > jQuery Colorbox, should it prefix the wp_enqueue_script/style handles
> > with the theme name, or should it use a generic name?
> > wp_enqueue_script( 'nivo-slider', ... );
> > vs
> > wp enqueue_script( 'themename-nivo-slider', ... );
> > Thanks!
> > --
> > Konstantin
> > _______________________________________________
> > theme-reviewers mailing list
> > theme-reviewers at lists.wordpress.org
> > http://lists.wordpress.org/mailman/listinfo/theme-reviewers
> theme-reviewers mailing list
> theme-reviewers at lists.wordpress.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the theme-reviewers