[wp-hackers] wp_list_pages

Adi Sieker ml at sieker.info
Sat Dec 11 16:47:18 UTC 2004

Chris Waigl wrote:
> Oops you're fast -- I only saw that you're working on this a few hours ago.
hehe, I got some extra free time in. :)

> I'm still a very basic-level coder, but it happens that I slightly
> rewrote the existing function, too. No hierarchies, but there are two
> things I don't think you did: a) add a class "current" to the list
> item of the current page (for menu styling) and remove the hyperlink
> from that item and 
OK, that sounds good. I'll see how that fits in best with what I have

 > b) an option not to print but to return an array of
> pages.
I think I'd rather split the function in this case. So
we'd have one get_list_pages which returns the array
and one wp_list_pages which returns the formatted list and
which uses get_list_pages. I think that naming scheme also fits
in with the API rules RyanB suggested a while back.

[function snipped]


Adi J. Sieker
Freelance developer

More information about the hackers mailing list