[buddypress-trac] [BuddyPress Trac] #8470: Improve BP Directory Pages Administration parts

buddypress-trac noreply at wordpress.org
Sun Oct 10 04:05:12 UTC 2021

#8470: Improve BP Directory Pages Administration parts
 Reporter:  imath           |       Owner:  imath
     Type:  enhancement     |      Status:  reopened
 Priority:  normal          |   Milestone:  10.0.0
Component:  Administration  |     Version:
 Severity:  normal          |  Resolution:
 Keywords:  needs-patch     |
Changes (by imath):

 * keywords:  has-patch => needs-patch
 * status:  closed => reopened
 * resolution:  fixed =>


 Thanks for your feedback @Offereins

 No problem to add the `$post` parameter to the filter 👌.

 The method you're referring to is overridden by components ones where the
 check for `$post` being the actual directory page is already made. The
 `$this->has_directory` could be done into these methods as well, but I've
 put it into the parent method to avoid too much code duplication. Each
 components method is using the parent method to use this check and the

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/8470#comment:7>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list