[buddypress-trac] [BuddyPress Trac] #7277: BP 2.8 - Prevent loading if PHP < 5.3

buddypress-trac noreply at wordpress.org
Thu Jan 19 19:25:11 UTC 2017

#7277: BP 2.8 - Prevent loading if PHP < 5.3
 Reporter:  r-a-y                  |       Owner:  boonebgorges
     Type:  defect (bug)           |      Status:  assigned
 Priority:  highest                |   Milestone:  2.8
Component:  Core                   |     Version:
 Severity:  blocker                |  Resolution:
 Keywords:  has-patch 2nd-opinion  |

Comment (by boonebgorges):

 In [changeset:"11389"]:
 #!CommitTicketReference repository="" revision="11389"
 Prevent BuddyPress from loading when the minimum PHP version is not met.

 When the server is running a version of PHP lower than 5.3.0, an
 admin notice is thrown, and the rest of BuddyPress is not loaded.

 The bp-loader.php file must remain compatible with WP's minimum PHP
 version, to prevent fatal errors when activating BuddyPress. In order
 to reduce the cognitive overhead involved in maintaining PHP compat
 for this file, the `BuddyPress` class has been moved into its own
 class-buddypress.php file.

 Props r-a-y.
 See #7277.

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/7277#comment:7>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list