[buddypress-trac] [BuddyPress Trac] #6331: Star Private Messages

buddypress-trac noreply at wordpress.org
Mon Apr 27 22:17:12 UTC 2015

#6331: Star Private Messages
 Reporter:  r-a-y                   |       Owner:  r-a-y
     Type:  enhancement             |      Status:  assigned
 Priority:  normal                  |   Milestone:  2.3
Component:  Component - Messaging   |     Version:
 Severity:  normal                  |  Resolution:
 Keywords:  dev-feedback has-patch  |
Changes (by r-a-y):

 * keywords:  dev-feedback => dev-feedback has-patch


 `01.patch` adds support for starring private messages.  It tries to do so
 in a less-intrusive manner.

 Let's say you don't want this feature enabled.  Add this code snippet:

 `add_filter( 'bp_messages_is_starred_enabled', '__return_false' );`

 And this prevents the inclusion of the `bp-messages-starred.php` file.
 I'd preferably like all new functionality to follow a similar approach for
 upcoming BP features.  Thoughts?

 Unlike the proof-of-concept plugin, I added a template tag function and
 added it into the `messages-loop.php` and `single.php` templates because
 theme developers might be interested as to what the code is so they can
 move it around in their custom templates if desired.

 What I'd like some feedback on is the naming convention of some of the

 * `bp_messages_is_starred_enabled()`
 * `bp_messages_starred_action_link()` - The messages-loop.php template
 uses function names like `bp_message_thread_delete_link()` and
 `bp_message_thread_view_link()`, but also
 `bp_the_message_thread_mark_unread_url()`. Should this function be named
 `bp_messages_the_starred_action_link()`?  Keep in mind that this function
 can be used in both `/members/single/messages/messages-loop.php` and

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/6331#comment:9>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list