[buddypress-trac] [BuddyPress Trac] #5436: BP_Core shouldn't run on 'bp_setup_components'

buddypress-trac noreply at wordpress.org
Mon Jun 2 20:10:40 UTC 2014

#5436: BP_Core shouldn't run on 'bp_setup_components'
 Reporter:  r-a-y                  |       Owner:
     Type:  defect (bug)           |      Status:  new
 Priority:  high                   |   Milestone:  2.1
Component:  Core                   |     Version:
 Severity:  normal                 |  Resolution:
 Keywords:  has-patch 2nd-opinion  |

Comment (by boonebgorges):

 I think there's some benefit to our subhooks being specific. If someone
 doesn't like the specific name but wants to hook in at the same point,
 they could hook directly to `'bp_init'`. You could make the same argument
 for, eg, `'bp_setup_nav'`.

 If we must go with a more general name, let's at least tie it somewhat to
 its intended functionality, rather than simply describing its load order
 as "late" (which is a bit of a misnomer anyway - it's pretty early in the
 BP load process). The key idea is that this is a chance for components to
 set up globals that (a) need to be run early in the load process, but (b)
 are dependent on all of the core components' being registered. So maybe
 something like `'bp_setup_secondary_globals'`?

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/5436#comment:11>
BuddyPress Trac <http://buddypress.org/>
BuddyPress Trac

More information about the buddypress-trac mailing list