[buddypress-trac] [BuddyPress] #5020: BP_Feed class

buddypress-trac noreply at wordpress.org
Mon Jun 3 17:04:16 UTC 2013

#5020: BP_Feed class
 Reporter:  r-a-y        |       Owner:
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  1.8
Component:  Activity     |     Version:
 Severity:  normal       |  Resolution:
 Keywords:  has-patch    |

Comment (by johnjamesjacoby):

 This is really great. A few things:

 * Rename BP_Feed to BP_Activity_Feed (other components might have other
 kinds of feeds)
 * Change namespace from 'bp_feed' to 'bp_activity_feed' per above, in
 * Rather than hook to 'bp_actions' does it make sense to have a new hook
 for 'bp_feeds' -- Haven't thought this through, but wondering if all feeds
 should be hooked to the same action, to make them easy to unhook later?
 * Do members have activity feeds that need doing?

 Let's fix up these bits, and get this in for 1.8.

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/5020#comment:5>
BuddyPress <http://buddypress.org/>

More information about the buddypress-trac mailing list