[buddypress-trac] [BuddyPress] #3905: BP not fully uninstalled after following the codex instructions

buddypress-trac at lists.automattic.com buddypress-trac at lists.automattic.com
Sat Jan 7 01:23:55 UTC 2012

#3905: BP not fully uninstalled after following the codex instructions
 Reporter:  MindTweaks    |      Owner:
     Type:  defect (bug)  |     Status:  new
 Priority:  normal        |  Milestone:  Awaiting Review
Component:  Core          |    Version:
 Severity:  normal        |   Keywords:
 Hello, Awesome BuddyPress Code Monkeys!

 Yesterday, I installed BP 1.5 on a fresh install of WP 3.3

 Something went wrong (I may not have completed the wizard, I'm not sure)
 and the install was incomplete - none of the BP content was displaying on
 the associated pages.

 I uninstalled BuddyPress as detailed here:

 buddypress/   and attempted a re-install.  The re-installation did not
 trigger the BP Install wizard. I saved the options on the
 components/pages/settings/forums tabs, but it didn't correct the problem,
 and it seemed that some BP information was still being stored somewhere,
 as it remembered the pages I'd set previously.

 I found the bb-config file, renamed it, uninstalled the BP plugin, and
 dropped the BP database tables again, and re-installed again, with the
 same result:  The installation wizard wasn't triggered, I didn't have a
 way of locating it and triggering it manually, and saving the individual
 options pages didn't change the way BP associated pages were being

 I went through the process several times to be sure I'd followed all of
 the steps correctly. Nothing changed.

 Today I started from scratch, re-installing a fresh copy of Wordpress, and
 the BP installation went fine.  To test the issue, I uninstalled BP again,
 and tried reinstalling - the installation wizard was still not being
 triggered.  The reinstalled plugin is, however, working correctly. (whew!)

 I've seen the same issue coming up on the support forums, too, and it
 could be a major problem if the plugin needs reinstalling on an
 extablished site, so I thought it worth reporting - there's either
 something wrong, or a missing step in the uninstall instructions.

 I'm using Buddypress 1.5.2
 I've had the same reinstallation issue with both Wordpress 3.3 and 3.3.1

 Here are the stats from my webhost in case you need them:
 Apache version  2.2.19
 PHP version     5.2.17
 MySQL version   5.0.92-community
 Architecture    x86_64
 Operating system linux
 Perl version    5.8.8
 Kernel version  2.6.18-238.19.1.el5.centos.plus

 Hope this helps find the problem!
 Tori Deaux

Ticket URL: <https://buddypress.trac.wordpress.org/ticket/3905>
BuddyPress <http://buddypress.org/>

More information about the buddypress-trac mailing list