[wp-trac] [WordPress Trac] #14761: unregister_post_type()

WordPress Trac noreply at wordpress.org
Sun Feb 7 02:33:22 UTC 2016

#14761: unregister_post_type()
 Reporter:  nacin                                |       Owner:  swissspidy
     Type:  enhancement                          |      Status:  reopened
 Priority:  normal                               |   Milestone:  4.5
Component:  Posts, Post Types                    |     Version:  2.9
 Severity:  normal                               |  Resolution:
 Keywords:  early has-patch has-unit-tests       |     Focuses:
  commit                                         |
Changes (by DrewAPicture):

 * status:  closed => reopened
 * resolution:  fixed =>


 I think we should rename `unregister_post_type()` to
 `deregister_post_type()`. Semantics? Maybe. But I think it's worth

 The basic issue is that "unregister" isn't really a word. In fact, the
 only context in which "unregister" is really valid is when describing the
 ''state'' of a post type registration. The ''action'' is registration vs

 For instance: '''An unregistered (state) post type is one that has been
 deregistered (verb).'''

Ticket URL: <https://core.trac.wordpress.org/ticket/14761#comment:44>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform

More information about the wp-trac mailing list