[wp-trac] [WordPress Trac] #28709: Improve/introduce Customizer JS models for Controls, Sections, and Panels

WordPress Trac noreply at wordpress.org
Sun Oct 26 07:17:35 UTC 2014


#28709: Improve/introduce Customizer JS models for Controls, Sections, and Panels
------------------------------------+-------------------------
 Reporter:  westonruter             |       Owner:
     Type:  enhancement             |      Status:  new
 Priority:  high                    |   Milestone:  4.1
Component:  Customize               |     Version:
 Severity:  normal                  |  Resolution:
 Keywords:  has-patch dev-feedback  |     Focuses:  javascript
------------------------------------+-------------------------

Comment (by westonruter):

 In [attachment:28709.wip.7.diff]:

  * Rename `onToggle*` to `onChange*`
  * Move `WidgetControl` duration to `defaultExpandedArguments`
  * Short-circuit `expand`/`collapse`, `activate`/`deactivate` if already
 set
  * Make sure `Control.activate`/`Control.deactivate` take params
  * Update `WidgetControl.collapse`/`WidgetControl.expand` to accept params
  * `api.Section.focus()` and `api.Control.focus()`
  * Support `allowMultiple` option on `Section.expand()`
  * Factor out duplicate logic from `expand`/`collapse`,
 `activate`/`deactivate`; always call `completeCallback`
  * Expand contained panel first before expanding section
  * Update `Section.focus` to build upon `Section.expand`
  * Consolidate `focus` into one shared method reused by Panels, Sections,
 Controls

 Also props @kienstra @celloxpressions

--
Ticket URL: <https://core.trac.wordpress.org/ticket/28709#comment:24>
WordPress Trac <https://core.trac.wordpress.org/>
WordPress publishing platform


More information about the wp-trac mailing list