[wp-trac] [WordPress Trac] #14401: Unable to locate WordPress Content directory (wp-content).

WordPress Trac wp-trac at lists.automattic.com
Mon Mar 21 22:53:55 UTC 2011

#14401: Unable to locate WordPress Content directory (wp-content).
 Reporter:  pavelevap        |       Owner:
     Type:  defect (bug)     |      Status:  reopened
 Priority:  normal           |   Milestone:
Component:  Upgrade/Install  |     Version:  3.0
 Severity:  normal           |  Resolution:
 Keywords:                   |
Changes (by pavelevap):

 * status:  closed => reopened
 * resolution:  invalid =>


 Sorry for changing version.

 I tried it in forums several months ago, but without answer.

 I will summarize the whole problem - and try to explain why it can be WP
 related problem...

 I am familiar with wp-config.php settings, but this case is special. No
 constant can solve my issue. Problem with installing/upgrading (ftpext and
 ftpsockets) has 2 parts:

 Info from Core Control plugin (and phpinfo):

 Direct Not Available

 SSH2 Not Available

 PHP FTP Extension Available

 PHP FTP Sockets Available

 1) First problem when using "ftpext" method.

 Error: "Unable to locate WordPress Content directory (wp-content)."

 Even if constants FTP_BASE, FTP_CONTENT_DIR and FTP_PLUGIN_DIR defined,
 for example:

 define('FTP_BASE', '/home/www/domain.eu/subdomains/www/');
 define('FTP_CONTENT_DIR', '/home/www/domain.eu/subdomains/www/wp-
 define('FTP_PLUGIN_DIR', '/home/www/domain.eu/subdomains/www/wp-

 I ended with following error:

 "Could not create directory. /home"

 I also do not understand why /home is the problematic directory? There is
 no need to create /home directory... No way to install/upgrade WordPress
 or plugins this way.

 2) When I tried "ftpsockets", following error appears:

 Warning: socket_last_error() expects parameter 1 to be resource, null
 given in /srv2/www/domain.eu/subdomains/www/wp-admin/includes/class-ftp-
 sockets.php on line 59

 I noticed one problem, that WordPress thinks that address starts with
 /srv2/www (see socket error) but my phpinfo starts DOCUMENT_ROOT with
 /home/www. Please see error messages. When using ftpext, /home is used by
 Wordpress, but when using ftpsockets, /srv2 is used.

 Sorry for reopening ticket once again, but after testing upgrade constants
 it may be problem on WP side, I guess...

Ticket URL: <http://core.trac.wordpress.org/ticket/14401#comment:11>
WordPress Trac <http://core.trac.wordpress.org/>
WordPress blogging software

More information about the wp-trac mailing list