[wp-hackers] PHP 5.2 that WordPress 3.2 requires
otto at ottodestruct.com
Sun Jul 25 05:55:23 UTC 2010
I think we need to step back and understand the reason for the version
change a second.
If a host sees "WordPress is only going to support PHP 5.2 in the
future", and they currently run PHP 4, and a lot of their customers
run WP, then they're going to upgrade pronto.
At the same time, they're probably going to upgrade to the latest PHP
they get their hands on which is also considered stable. This
naturally excludes PHP < 5.3.4.
What it comes down to is this: I don't think it makes any difference
whether WP says "5.2.0" or "5.2.4". It's a non-issue. The hosts on top
of their things are already fine. The ones that are not are either not
going to notice and stuff breaks, or they'll have somebody competent
do their upgrades and they'll be fine.
So relax. Just say "5.2" and be done with it. If it's a problem, then
it'll be a minority issue and we'll workaround it or tell hosts "hey,
you're running old broken crap" and they'll fix it.
On Sat, Jul 24, 2010 at 11:04 PM, Franklin Tse
<peaceable_whale at hotmail.com> wrote:
> From: "Jacob Santos" <wordpress at santosj.name>
> Date: Sunday, 25 July, 2010 06:12
> To: <wp-hackers at lists.automattic.com>
> Subject: Re: [wp-hackers] PHP 5.2 that WordPress 3.2 requires
>> I agree with Nacin with this one. Just because the requirement is for
>> PHP 5.2.0, doesn't mean the server is required to use that version and
>> thankfully most should be at least PHP 5.2.2-6. It will be relatively
>> simple to test on latest for development and then switch to PHP5.2.0 for
>> regression testing and developing workarounds.
> If the most servers are at least PHP 5.2.2-6, there might not be a very good reason for WordPress to stay in a less commonly used version.
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
More information about the wp-hackers