[wp-hackers] Script Install of WordPress Lastest

Ken Newman Ken at adcSTUDIO.com
Sat Feb 13 01:26:52 UTC 2010

Thanks for the Quick reply.

I checked and Plugin installs work fine. (Installed WordPress Beta Tester)

  I did a completely fresh install (new DB and everything) from that zip 
(http://wordpress.org/nightly-builds/wordpress-latest.zip) and that 
worked fine too. It's only on update that it fails :-(

But atleast it isn't "something weird is up with the PHP Zip extension" :-)

Note this is my testing server, and it doesn't matter if it gets nuked.

I'll test again with a manually uploaded, unzipped version to see if it 
corrects. (It takes forever, which is what I was trying to avoid ;-)

Thanks again!

On 2/12/2010 8:03 PM, Dion Hulse (dd32) wrote:
> Does your PHP install have the ZIP extension available?
> Do Plugin Installs suceed?
> Generally, Upgrade/Installs errors are due to incomplete Zip downloads.
> If it fails consistantly, try disabling the zip extension:
> add_filter('unzip_file_use_ziparchive', create_function('', 'return 
> false;'));
> If that doesnt help (And i *hope* it doesnt.. because that'll mean 
> something weird is up with the PHP Zip extension), Then try installing 
> my plugin 'Core Control', Activate the HTTP Access module, and try 
> disabling the current default transport.. See if that helps you at all
> On Sat, 13 Feb 2010 11:30:35 +1100, Ken Newman <Ken at adcstudio.com> wrote:
>> Hello Hackers,
>> What I've tried doing is uploading a php file with the following:
>> <?php exec('wget 
>> http://wordpress.org/nightly-builds/wordpress-latest.zip');
>> exec('unzip wordpress-latest.zip'); ?>
>> This grabs the latest nightly and unzips. So far so good. I then go
>> through the steps to create the wp-config.
>> The problem appears to be when attempting an upgrade, I get the
>> following error:
>> Downloading update
>> fromhttp://wordpress.org/nightly-builds/wordpress-latest.zip…
>> Unpacking the update…
>> Incompatible Archive.
>> Installation Failed
>> It occurs to me that this might be unrelated to how I installed, but is
>> it possible that this is a user/creator file permission issue on the
>> LAMP stack? In other words, is LAMP treating the php script/server as
>> the owner of the files and directories and does that matter? I'm
>> assuming I wouldn't have an issue with a manual upload, and I can think
>> of any other difference, except my user would be the creator of the
>> files and directories rather then the system (if indeed that does work
>> that way).
>> Any ideas would be appreciated, Thanks,
>> Ken
>> _______________________________________________
>> wp-hackers mailing list
>> wp-hackers at lists.automattic.com
>> http://lists.automattic.com/mailman/listinfo/wp-hackers

More information about the wp-hackers mailing list