[wp-hackers] "Warning: This plugin has not been tested with your
current version of WordPress."
wordpress at dd32.id.au
Fri Jan 16 08:29:36 GMT 2009
It was just an oversight not to mention the warning if the tested
field wasnt set..
The warning doesnt mention that its not compatble (It does if it
requires WP 2.8 and you're running 2.6 tho), only that it hasnt been
tested.. In the event that the tested field isnt set, then you're
right, It shouldnt show the message.. If you open a trac ticket, i'll
do it (as well as only checking major version numbers, ignoring minor
updates) else i'll open one later on.
2009/1/16 Ozh <ozh at planetozh.com>:
> wordpress at dd32.id.au:
>>Whats the "Tested up to" field set to?
>>I'm guessing that the plugin in question doesnt have the 'tested' field
> The plugin header is:
> === Ozh' Who Sees Ads ===
> Requires at least: 2.5
> Stable tag: trunk
> So, no, no tested field. "Requires at least 2.5" means just that. It
> means "works from 2.5 to 6.0."
> "Warning: This plugin has not been tested with your current version of
> WordPress." is totally random and definitely not true. This is a
> "Warning: This plugin MIGHT not be compatible with your version, ALTHOUGH
> I don't have any real clue to assert this" would be a more accurate
> A *LOT* of plugin are totally version independant. They're just basic
> filters and actions.
> I think I'm going to put a dummy "tested up to: 9.99" and never bother
> again with that.
> jeremy.visser at gmail.com:
>>I get that impression too, but I think it makes sense, because there is
>>always a risk that a plugin will break with a new WP version.
> To me it would make sense if the readme.txt made sense.
> wp-hackers mailing list
> wp-hackers at lists.automattic.com
More information about the wp-hackers