[wp-hackers] Idea: Rename the Excerpt to something accurate
jer at simianuprising.com
Sat Feb 28 17:35:01 GMT 2009
Lots of good stuff has already been said. -1 for auto-filling the
excerpt box for the stated reasons.
I think the #1 argument in favor of changing the function/UI name (#2
is the fact that Summary WOULD be a better description, only
auto-excerpts are better referred to as excerpts) is the plain fact
that the_excerpt() is a shame unto WordPress. From what I can tell its
the same function from the original announcement years ago except
there is one useless deprecated argument blocking anyone from
improving its use.
IMHO whatever function is used to show these lead-ins needs to accept
a wp_parse_args() set of arguments that allow for things like
length=50, before=$before_text and skip-auto=1. As it is the function
is basically useless compared to the rest of WP and just isn't up to
Everyone always says "so write a patch" but its hard when the existing
function is held back by its history. the_summary() could be a way
around that, though I'd be happy to just let loose whoever still has
that second parameter and move on with our excerpting lives.
Controlling excerpts with arguments isn't plugin territory, it should
definitely be in core. There should also be a filter on them and THAT
is plugin territory.
Jeremy Clarke | http://simianuprising.com
Code and Design | http://globalvoicesonline.org
More information about the wp-hackers