[wp-hackers] Plugins and supporting old versions of WordPress
viper at viper007bond.com
Thu May 8 11:29:37 GMT 2008
Philosophy question time.
I'm currently re-coding a plugin of mine and the new version will require
jQuery which was added in WP 2.2.0. Bundling jQuery for people using 2.0.x
isn't worth my trouble (plus no script loader) and they can just use the
older versions of my plugin. Less features, but hey, it's their own fault
for running an old version.
So to the question: what should be the minimum WP version for the new
version of my plugin? Should I allow the plugin to run on the real min specs
(2.2) or put in an arbitrary minimum version of 2.3.3 or even better, 2.5?
Obviously I can choose to support whatever versions I wish -- it is my
plugin after all that people can chose to use or not to use. However, do you
think it's my place to be providing incentives for people to upgrade (it's
in their best interest anyway)? Or is that their business and not mine and I
should do my best to support old versions?
If I were making use of 2.5-only functions, this wouldn't be an issue -- I'd
drop support for old versions in a heartbeat, but since my plugin could
technically work with 2.2+, I'm having a tough time deciding whether to go
with the carrot and stick approach or not.
Thanks in advance for any opinions. :)
Viper007Bond | http://www.viper007bond.com/ | http://www.finalgear.com/
More information about the wp-hackers