[wp-hackers] Plugins -- new header fields: max-compatible and
wp-hackers at striderweb.com
Wed Apr 2 21:20:41 GMT 2008
On Apr 2, 2008, at 3:16 PM, Christian Holtje wrote:
> On Apr 2, 2008, at 4:03 PM, Peter Westwood wrote:
>>> On Mar 31, 2008, at 8:39 PM, Stephen Rider wrote:
>>>> Here's a thought. It might be useful to allow for new plugin
>>>> header fields: "max-compatible" and "min-compatible". It would
>>>> allow plugin developers to specify WP versions that the plugin is
>>>> known to work with.
>>> What significant benefit do these have over the existing fields in
>>> the readme.txt standard.
>> Requires at least: 2.0.2
>> Tested up to: 2.1
> What we're asking for is notification in admin interface, so that
> the user knows. In fact, I like Requires at least and Tested up to.
> Better names than min and max.
> "Requires at least" should be a hard-coded limit. It just won't
> activate if WP is less than that version.
> "Tested up to" should indicate it's untested visually somehow yet
> still run.
Christian gave two good reasons;
1) When upgrading I don't have to slog through source files looking
for what's going to work and what's not.
2) With hard limits, WordPress can programatically _not_ activate any
plugins that are known not to work with that version. The Drop Down
Admin Menu plugin is a good example. There is a version that flatly
**will not work** in WordPress 2.5. if we had these limits
implemented, WordPress could know not to activate. Same with the
later version that _only_ works with 2.5
Yes, plugin authors can put in logic that tests for versions, but this
would be a standard one-line header. It could alert the user directly
that there is (or may be) an issue.
From another angle: What significant benefit do one-click plugin
updates have over uploading files via FTP? Simple: less screwing
around with source files.
>>> "Requires at least" should be a hard-coded limit. It just won't
>>> activate if WP is less than that version.
>>> "Tested up to" should indicate it's untested visually somehow yet
>>> still run.
You're probably right on that one. The "tested up to" should also
probably only flag it if it's a significant decimal -- e.g if it's
tested on v2.3, it should _not_ flag 2.3.3 as untested, but 2.5 yes.
More information about the wp-hackers